最准的自动画线指标公式源码,通达信指标中如何自动画线

内容导航:
  • 通达信指标中如何自动画线
  • 求通达信自动画线公式
  • 网上找到一份通达信自动画线的源码,但不知道怎么导入进去,有没有知道的大师,能帮小白解决???
  • 求前期高低点画线代码?求前期高低高点自动画线代码?
  • 同花顺看盘软件画图箭头
  • 如何在同花顺K线上标注小箭头
  • Q1:通达信指标中如何自动画线

    自动画线太多了,给你一个我看好的,源码下面网址里有图片演示.
    该指标能够做到对前期高点和最近高点的连线、前期低点和最近低点的连线、阻力位和支撑位的平行直线的连线,可以说简单易懂,一目了然。这类指标要用到未来函数,通常不做为买卖信号的参考。但该指标在一定周期内根据K线的走势所画的线已经成立,因此股价突破前高或颈线的点位还是比较可靠的,大家不妨在实战中来验证。所以,除了主图以外,还编制了选股指标。
    指标中的实线为高、低点连线,虚线为阻力位和支撑位。
    该指标可以复制粘贴到任何主图里。
    MA7:MA(C,7),COLORWHITE;
    MA14:MA(C,14),COLORYELLOW;
    MA25:MA(C,25),COLORFF00FF;
    MA120:MA(C,120),COLORFFCC66;
    QA:=REF(H,10)=HHV(H,2*10+1);
    QB:=BACKSET(QA,10+1);
    QC:=FILTER(QB,10) AND H=HHV(H,10+1);
    QD:=BARSLAST(QC);
    QE:=IF(QC,CURRBARSCOUNT,0);
    QF:=IF(QD,REF(QE,QD),QE);
    QG:=CONST(QF);
    QH:=REF(QF,QD+1);
    QW:=CONST(QH);
    DRAWLINE(CURRBARSCOUNT=QW,H,CURRBARSCOUNT=QG,H,1),COLORGREEN;
    DRAWLINE(CURRBARSCOUNT=QW,H,ISLASTBAR,REF(H,QW-1),1),COLOR0099FF,POINTDOT;
    DRAWLINE(CURRBARSCOUNT=QG,H,ISLASTBAR,REF(H,QG-1),1),COLOR0099FF,POINTDOT;
    QM:=INTPART(3*8/5);
    QR:=REF(H,QM)=HHV(H,2*QM+1);
    QT:=FILTER(QR,QM);
    QY:=BACKSET(QT,QM+1);
    QU:=FILTER(QY,QM);
    QI:=BACKSET(ISLASTBAR,BARSLAST(QU)+1);
    QP:=QI>REF(QI,1);
    DRAWLINE(QU,H,QP,H,1),COLORRED;
    QA1:=REF(L,8)=LLV(L,2*8+1);
    QB1:=BACKSET(QA1,8+1);
    QC1:=FILTER(QB1,8) AND L=LLV(L,8+1);
    QD1:=BARSLAST(QC1);
    QE1:=IF(QC1,CURRBARSCOUNT,0);
    QF1:=IF(QD1,REF(L,QD1),L);
    QG1:=IF(QD1,REF(QE1,QD1),QE1);
    QH1:=CONST(QG1);
    QW1:=REF(QF1,QD1+1);
    QM1:=REF(QG1,QD1+1);
    QR1:=CONST(QM1);
    DRAWLINE(CURRBARSCOUNT=QR1,L,CURRBARSCOUNT=QH1,L,1),COLORBLUE;
    DRAWLINE(CURRBARSCOUNT=QH1,L,ISLASTBAR,REF(L,QH1-1),1),COLORWHITE,POINTDOT;
    DRAWLINE(CURRBARSCOUNT=QR1,L,ISLASTBAR,REF(L,QR1-1),1),COLORWHITE,POINTDOT;
    QT1:=REF(L,QM)=LLV(L,2*QM+1);
    QY1:=FILTER(QT1,QM);
    QU1:=BACKSET(QY1,QM+1);
    QI1:=FILTER(QU1,QM);
    QP1:=BACKSET(ISLASTBAR,BARSLAST(QI1)+1);
    QJ1:=QP1>REF(QP1,1);
    DRAWLINE(QI1,L,QJ1,L,1),COLORRED;
    SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
    SR2:=FILTER(SR1,10);
    SR3:=BACKSET(SR2,10+1);
    HD:=FILTER(SR3,10);
    前高:=REF(H,BARSLAST(HD));
    DRAWICON(CROSS(C,前高),L-0.20,3);{突破前高的信号}

    Q2:求通达信自动画线公式

    这个问题要参考绘图函数DRAWLINE的应用,举例如下:
    DRAWLINE 绘制直线段
    在图形上绘制直线段。
    用法:DRAWLINE(COND1,PRICE1,COND2,PRICE2,EXPAND)
    当COND1条件满足时,在PRICE1位置画直线起点,当COND2条件满足时,在PRICE2位置画直线终点,EXPAND为延长类型。
    例如: DRAWLINE(HIGH>=HHV(HIGH,20),HIGH,LOW<=LLV(LOW,20),LOW,1) 表示在创20天新高与创20天新低之间画直线并且向右延长。
    由于你提供的信息有限,只能回答到这一步了,仅供参考。

    Q3:网上找到一份通达信自动画线的源码,但不知道怎么导入进去,有没有知道的大师,能帮小白解决???

    通达信公式导入安装方法


    通达信公式导入操作步骤如下(下面举例以说明):

    1、先将我们传送的文件解压到你选择的硬盘位置,记住文件存档位置。找到所接收文件。

    2、点击该文件,打开,如图,并点击“解压到”。然后选择文件存放位置,记住文件存放位置。

    3、打开交易软件到行情显示窗口,点击“功能”按钮,在“专家系统”里选“公式管理器”,点击进入。在公式管理器窗口点击“导入公式”



    4、选择导入文件,点击返回按钮,点击“我的电脑”,点击窗口右下方的“打开”按钮,找到刚才存放文件的硬盘,打开,找到存放文件的文件夹,选择该文件,打开。截图介绍如下,一步一步进行。(注意:此处是以副图指标导入举例。其它如主图,同于副图,选股公式导入到“条件选股公式”里,交易系统公式导入到“交易系统公式”里即可。安装步骤基本一样,若通达信的版本有细微差别,请诸君按照基本步骤做就行了。有差别的地方,可以结合诸君自己的版本稍作改动。)


    5、找到文件点击打开后,公式开始导入软件系统。在“其它类型”前的方框里点一下,然后点右下方的“确定”按钮,公式就导入到系统里了。一般导入到“其它类型”里,是为了查找方便。主图及副图公式自动归入“技术指标公式”类,选股公式自动归入“条件选股公式”类,交易系统提示公式自动归入“交易系统公式”类。公式成功导入后,点击“关闭”按钮,退出公式管理器。

    6、回到行情窗口,任选个股,按Enter键进入走势分析窗口,先点副图框一下,以确定将该副图更换为我们需要的副图,再点击“全部”按钮,再点“技术指标”类下的“其它类型”前的+号,找到刚才导入的指标公式,然后点“确定”。

    7、然后,刚才的副图就换成我们需要的副图了,当然,我们可以任意更换所需要的指标。


    8、主图指标的选择与副图相似,但略有不同,故简介于次:在主图上点右键,再点“主图指标”,然后点“选择主图指标”,进入主图指标类,选择刚才导入的主图公式或其它我们要查看的主图公式,点“确定”,就行了。


    确定后,一般情况下,通达信系统会自动设为默认,下次打开行情分析时,出现的就是这次选择的指标,若有时出现变化,可以重新进行一次设定就好。




    股票公式专家团为你解答,希望能帮到你,祝投资顺利。

    Q4:求前期高低点画线代码?求前期高低高点自动画线代码?

    前期高低点画线代码
    将下面的代码加入均线系统中就OK了
    一、通信达
    VAR31:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
    VAR41:=CROSS(VAR31,0.9);
    VAR51:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
    VAR61:=CROSS(VAR51,0.9);
    压力:= REF(HIGH,BARSLAST(VAR41));
    STICKLINE(C,REF(HIGH,BARSLAST(VAR41)),REF(HIGH,BARSLAST(VAR41)),8,1),COLOR00FFFF;
    支撑:= REF(LOW,BARSLAST(VAR61));
    STICKLINE(C,REF(LOW,BARSLAST(VAR61)),REF(LOW,BARSLAST(VAR61)),8,1),COLORRED;
    DRAWICON(CROSS(C,压力),L*1.00,7);
    DRAWICON(CROSS(支撑,C),H*1.00,8);
    二、博易大师
    VAR31:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
    VAR41:=CROSS(VAR31,0.9);
    VAR51:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
    VAR61:=CROSS(VAR51,0.9);
    压力:= REF(HIGH,BARSLAST(VAR41));
    STICKLINE(C,REF(HIGH,BARSLAST(VAR41)),REF(HIGH,BARSLAST(VAR41)),8,1),COLOR00FFFF;
    支撑:= REF(LOW,BARSLAST(VAR61));
    STICKLINE(C,REF(LOW,BARSLAST(VAR61)),REF(LOW,BARSLAST(VAR61)),8,1),COLORRED;
    DRAWICON(CROSS(C,压力),L*1.00,1);
    DRAWICON(CROSS(支撑,C),H*1.00,2);
    三、深发展国际金融信息平台
    VAR31:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
    VAR41:=CROSS(VAR31,0.9);
    VAR51:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
    VAR61:=CROSS(VAR51,0.9);
    压力:= REF(HIGH,BARSLAST(VAR41));
    STICKLINE(C,REF(HIGH,BARSLAST(VAR41)),REF(HIGH,BARSLAST(VAR41)),8,1),COLOR00FFFF;
    支撑:= REF(LOW,BARSLAST(VAR61));
    STICKLINE(C,REF(LOW,BARSLAST(VAR61)),REF(LOW,BARSLAST(VAR61)),8,1),COLORRED;
    DRAWICON(CROSS(C,压力),L*1.00,0);
    DRAWICON(CROSS(支撑,C),H*1.00,1);

    Q5:同花顺看盘软件画图箭头

    还是这样的啊?

    Q6:如何在同花顺K线上标注小箭头

    找出画线工具栏,就可以标了

    上一篇:上一篇:延期回购是利好还是利空
    下一篇:下一篇:炒股养家老师
    • 评论列表

    发表评论: