通达信公式ma,通达信选股公式:MA5金叉MA10后,收盘价一直在MA10以上的选股公式

内容导航:
  • 通达信选股公式:MA5金叉MA10后,收盘价一直在MA10以上的选股公式
  • 通达信函数 MA EMA 有何区别?
  • 通达信公式在下面公式里面加上ma均线
  • 请帮忙编写符合下列条件的选股公式(通达信)MA5>MA10;MA10>MA30;MA5上...
  • 怎样编写通达信公式?
  • 编写通达信公式,设置参数和不设置,有区别吗?
  • Q1:通达信选股公式:MA5金叉MA10后,收盘价一直在MA10以上的选股公式

    SC:=CROSS(MA(C,5),MA(C,10));

    T:=BARSLAST(SC);

    xg:T>=1 AND C>=MA(C,10);

    Q2:通达信函数 MA EMA 有何区别?

    MA是移动平均,MA(CLOSE,5)的算法是把最近5天的收盘价加起来再除以5.
    EMA是指数移动平均线,有的软件简称为EXPMA,是一种加权的移动平均线指标。与简单移动平均线相比,指数移动平均线为近期的价格赋予较大的权重,同时又综合考虑了股票上市以来的所有交易价格。以12日EMA为例,其计算方法如下:
    W=2÷(12+1)=0.1538
    EMA(12)=(收盘价-昨日的EMA)×0.1538+昨日的EMA
    参考

    Q3:通达信公式在下面公式里面加上ma均线

    VAR3:=LLV(HIGH,240);
    VAR4:=100*(CLOSE-VAR3)/VAR3;
    VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
    VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
    VAR7:=0;
    VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
    VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
    VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
    VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
    VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
    VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
    VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
    VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
    VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
    VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
    VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
    VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
    买1:=VAR10;
    买2:=(VAR11+VAR13+VAR15+VAR17);
    卖1:=(VAR12+VAR14+VAR16+VAR18);
    B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
    DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'买入'),COLORRED;
    S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
    DRAWTEXT(卖1>0,HIGH*1.02,'卖出'),COLORGREEN;
    {股灵吧决策}
    VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
    VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
    VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
    A:=BARSCOUNT(C);
    AH:=HHV(H,200);
    AL:=LLV(L,200);
    A0:=(AH-AL)/40;
    B1:=L-A0;
    STICKLINE((A+0)/34=FLOOR((A+0)/34),B1,B1-1.5*A0,3,0),COLORF00FF0;
    DRAWTEXT((A+0)/34=FLOOR((A+0)/34),B1-1*A0,'时间窗'),COLORWHITE;
    ma:ma(c,5) ;

    Q4:请帮忙编写符合下列条件的选股公式(通达信)MA5>MA10;MA10>MA30;MA5上...

    MA5:=MA(C,5);
    MA10:=MA(C,10);
    MA30:=MA(C,30);
    XG:MA5>MA10 AND MA10>MA30 AND CROSS(MA5,REF(MA5,1)) AND CROSS(MA10,REF(MA10,1)) AND MA30>REF(MA30,1);

    (已测试)

    Q5:怎样编写通达信公式?

    可以编写,但你也没说买入条件,也没有计算价格。所以只能出一个大概示意图。

    例如下图上穿20日线买进提示。20日内再次发上穿就不再发出买入提示。

    涨到1.2倍或者达到20个交易日哪个先满足就卖出提示。

    效果如下图

    买进红色字,1.2倍卖出黄色字,20个交易日卖出绿色字。

    Q6:编写通达信公式,设置参数和不设置,有区别吗?

    如果不准备经常修改参数,就没必要进行参数设置,直接给出固定的值就好了。何必找那个麻烦

    上一篇:上一篇:国光连锁605188
    下一篇:下一篇:金融股票群
    • 评论列表

    发表评论: